Announcement

Collapse
No announcement yet.

Error building from source

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Error building from source

    Hello,

    I have followed the instructions from:

    https://github.com/bridgedotnet/Brid...ld-From-Source

    using the master branch, but I've got this erros while building the solution:

    Warning Found conflicts between different versions of "Microsoft.Build.Framework" that could not be resolved. These reference conflicts are listed in the build log when log verbosity is set to detailed. Bridge.Build

    Error Microsoft.Build.Exceptions.InvalidProjectFileExcep tion: The tools version "15.0" is unrecognized. Available tools versions are "14.0", "2.0", "3.5", "4.0". D:\Manu\Documents\Visual Studio 2017\Projects\bridge\Bridge\Bridge\Bridge.csproj Bridge.PostBuild D:\Manu\Documents\Visual Studio 2017\Projects\bridge\Bridge\PostBuild\EXEC

    Error The command "
    REM Run Bridge Compiler for the project
    "D:\Manu\Documents\Visual Studio 2017\Projects\bridge\Bridge\Compiler\Builder\bin\R elease\bridge.exe" -p "D:\Manu\Documents\Visual Studio 2017\Projects\bridge\Bridge\Bridge\Bridge.csproj" -b "D:\Manu\Documents\Visual Studio 2017\Projects\bridge\Bridge\Bridge\bin\Release\Bri dge.dll" -cfg "Release" --platform "AnyCPU"
    " exited with code 1. Bridge.PostBuild

    Do I have to install something else?

    BR,
    Manu

    #2
    Somehow it fixed alone, after updating VS2017 to 15.7.4

    Comment


      #3
      The problem reapeared.

      I fixed it changing the Bridge.csproj from:

      <Project ToolsVersion="12.0"...
      to

      <Project ToolsVersion="14.0" ...
      As explained here:

      https://www.michalkomorowski.com/201...even-more.html

      Comment

      Working...
      X