Announcement

Collapse
No announcement yet.

New Bridge Project doesn't seem to work in VS 2017

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • New Bridge Project doesn't seem to work in VS 2017

    I'm using VS 2017, I added Bridge.Net as an extension, I selected the Bridge project and it is created. I built it and there is no Bridge folder created and of course no files within it. I tried everything twice removing the extension and re-adding it, rebooted the computer, etc.

    So far the .dll files appear in the bin directory but that's all. Any ideas what the issue could be up or perhaps what to look for?

  • #2
    So is the code that is generated work for everybody else or nobody else? Have I asked in the wrong place? Would it be beneficial if the project template worked?

    I'm confused.

    Comment


    • #3
      Hi tleylan,

      I just tried creating a new Bridge project from the Extension template, and it worked correctly. Is there any more information you can provide that would help us reproduce the problem?

      You can also install Bridge using NuGet to a new C# Class Library project.

      Comment


      • #4
        Thank you that is encouraging news. I'm using VS 2017 Community version. I installed the extension template and it didn't work. I see there is a minor version update of Bridge.Net don't know if that makes a difference but let me try it all again now that I know it works.

        Does it log anything I might be able to reference for you? All I noticed was the .dll was produced but no Bridge folder or files.

        Comment


        • #5
          I installed Visual Studio 2017 Community version and was able to add the Bridge.NET extension successfully. I was also able to create a new Bridge.NET project and compile. The correct JavaScript files were generated. Everything worked as expected.

          How about trying to remove the Bridge.NET extension, then install again?

          You can also download the .vsix installer file locally then double-click to install. You should remove the extension first, before installing the .vsix manually.

          https://marketplace.visualstudio.com...eNET.BridgeNET

          Hope this helps.

          Comment

          Working...
          X